Helpdesk technical support currently unavailable by phone, Please submit Support Requests
Incident Report for Synergy Wholesale
Resolved
We are now back online, Thanks everyone for your patience! Our teams are once again available by phone or via support requests. Please let us know at customercare@synergywholesale.com if you have any issues getting through
Posted 8 months ago. Jan 04, 2019 - 13:58 AEDT
Investigating
We are currently experiencing issues with power to our helpdesk teams in office. Currently we are pending restoration in the next 30 minutes with an electrician en route. Phone support will be unavailable at this time,

Please submit a Support Request for any issues and we'll get back to you ASAP.
Posted 8 months ago. Jan 04, 2019 - 12:40 AEDT
This incident affected: Support (Phone Support).