Technical support delays
Incident Report for Synergy Wholesale
Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 11:39 AEDT
Update
Due to current issues, our team won't be available for LiveChat, Phone Calls & Ticket responses.

We will provide updates as they become available.
Posted Jan 19, 2021 - 10:39 AEDT
Investigating
We will provide updates as they become available.
Posted Jan 19, 2021 - 10:38 AEDT
This incident affected: Support (Phone Support, Ticket Support).