Phishing email claiming to be Synergy Wholesale
Incident Report for Synergy Wholesale
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 11:51 AEST
Identified
Notice: We’re aware of a ‘phishing’ email being sent to generic/common addresses of domains registered with Synergy Wholesale requesting payment for your domain name. These emails are fraudulent and should be disregarded and marked as spam.

If you have clicked on the link within the email or submitted details through the attachment, please immediately update your password https://manage.synergywholesale.com/passwdreset
Posted May 12, 2021 - 15:58 AEST
This incident affected: Management Interface.